Please Consider A Small Donation

Please consider a small donation to help us cover our running cost,so that we can keep this site FREE for everyone.

Amount
×
Please consider a donation (10 Jul 2018)

Keep the Bongo Forum Alive

× Our old original forum has a searchable archive.

Question Revs won't go above 1500 - loses power - then stalls.

More
1 year 11 months ago #2757 by BongoDansk
BongoDansk created the topic: Revs won't go above 1500 - loses power - then stalls.
Beloved Bongo had been off the road for a year (just because we didn't need it) but we had upcoming plans to drive it to Denmark. So got taxed, insured etc and drove around for a week or two with no problems at all. So off we went on the journey to DK. Half way between London and DK (in Holland) the Bongo started to judder then lose power... and then would not rev above 1500... and would not change out of first gear (automatic). Next morning the Bongo would start OK, manage the 1500 revs max... but then start to lose power even whilst in neutral... and then stall. I had originally thought it nay be a fuel blockage, but garage tried bypassing the fuel filter etc and it seems to be something else.... maybe an injection problem. The garage had not seen a Bongo before and didn't know what to do. Finally got recovery to our destination in DK ....but could REALLY do with some advice on what the problem may be. Can anyone help??

Please Log in or Create an account to join the conversation.

More
1 year 11 months ago #2758 by teenmal
teenmal replied the topic: Revs won't go above 1500 - loses power - then stalls.
Try running with the fuel cap off, it does sound like fuel starvation ,when they bypassed the main filter did they make sure that the fuel pump filter was clean.? Did they draw fresh fuel from a container NOT the tank?, as some of these vehicles have a tank filter on the suction pipe. If all that is ok they will need to do a diagnostic check on the vehicle.

Good Luck

Please Log in or Create an account to join the conversation.

More
1 year 11 months ago #2759 by BongoDansk
BongoDansk replied the topic: Revs won't go above 1500 - loses power - then stalls.
I tried running without the cap and it still has the same problems. Thanks for the suggestion though! I few other people have suggested possible causes and I am working my way through the suggestions. Will update when its working again. Thanks again!

Please Log in or Create an account to join the conversation.

Time to create page: 0.197 seconds